[Openmcl-devel] Puzzled by NextStep method naming conventions

R. Matthew Emerson rme at clozure.com
Fri Jan 18 01:29:04 UTC 2008


On Jan 17, 2008, at 8:04 PM, Ron Garret wrote:

> ? (#/setColorAtX:y: rep (#/colorAtX:y: rep 0 0) 10 10)
> ? (#/setColor:AtX:y: rep (#/colorAtX:y: rep 0 0) 10 10)
>
> It really seems like one of those ought to work.  Why don't they?

The Objective-C message name is spelled "setColor:atX:y:" (note  
lowercase "a" in "atX').

(#/setColor:atX:y: rep (#/colorAtX:y: rep 0 0) 10 10)

would work.





More information about the Openmcl-devel mailing list