[Openmcl-devel] encodings

Joakim Sandgren info at joakimsandgren.com
Mon May 18 20:08:26 UTC 2009


Hi,
You showed me how to set the *default-file-character-encoding* and  
also the *default-external-format*...
As Gary showed me the Macintosh encoding works well for my accents and  
it does.
So I put Macintosh as my default encoding.
If I want to open a file, the Macintosh is preselected.
If I open a Macintosh encoded file and the take save as, the Macintosh  
encoding are pre-selected in that dialog.
If I do a new file it has the encoding "automatic".
When I save this new document for the first time it is "Automatic"  
encoding that is preselected.
There I choose Macintosh, and I save this document as a Macintosh  
encoded file.
When I open it, it is still Macintosh encoded.
I can evaluate, selected parts of the file with enter. But not I  
cannot use the Execute all... command in the menu or load the file  
with Load File.. in the menu.

If I load this file by using Load File... or Execute All I have :

 > Error: "MACINTOSH" is not the name of a known characer encoding.
 > While executing: MAKE-EXTERNAL-FORMAT, in process Listener(15).
 > Type :POP to abort, :R for a list of available restarts.
 > Type :? for other options.
1 >


I tried to put the external format to MACOS but it didn't have any  
effect...

Could someone enlighten me how to do?

Very Sincerely

Joakim



Joakim Sandgren
joakim sandgren musik
42, rue de Maubeuge
75009 Paris
France
+33 (0)1 45 26 43 90
info at joakimsandgren.com
http://www.joakimsandgren.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.clozure.com/pipermail/openmcl-devel/attachments/20090518/f3dd0996/attachment.html>


More information about the Openmcl-devel mailing list