[Openmcl-devel] Determining OSX version at runtime

Neil Baylis neil.baylis at gmail.com
Thu Aug 26 16:09:38 UTC 2010


I get the same on my 32 bit ppc system. My Intel 10.6 system gives version
as "10.4.0"

Is that the OSX version? (I'm running Snow Leopard).

Neil

On Thu, Aug 26, 2010 at 9:04 AM, Arthur Cater <arthur.cater at ucd.ie> wrote:

> Funnily enough I was wondering that very thing myself today.
> There's (software-type) and (software-version), which on my Leopard system
> give "Darwin" and "9.8.0".
> If they give different on Snow Leopard ...
> But maybe there's a more elegant solution.
>
> Arthur
>
>
> On Aug 26, 2010, at 4:51 PM, Neil Baylis wrote:
>
>  What's the correct way to determine the OSX version at runtime?
>>
>> Specifically, how do I make the behavior change if it's 10.6 or later?
>>
>> Neil
>> _______________________________________________
>> Openmcl-devel mailing list
>> Openmcl-devel at clozure.com
>> http://clozure.com/mailman/listinfo/openmcl-devel
>>
>
> _______________________________________________
> Openmcl-devel mailing list
> Openmcl-devel at clozure.com
> http://clozure.com/mailman/listinfo/openmcl-devel
>



-- 
http://www.pixpopuli.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.clozure.com/pipermail/openmcl-devel/attachments/20100826/0ed19536/attachment.html>


More information about the Openmcl-devel mailing list