[Openmcl-devel] %get-ip-interfaces returning nil

Elliott Slaughter elliottslaughter at gmail.com
Mon Jul 19 06:09:53 UTC 2010


Hi,

I have kind of a bizarre problem. I noticed recently that
ccl::%get-ip-interfaces returns nil for me, but just 3 or 4 months ago I
used to get a list of my network connections. I am running Windows 7 Pro
64-bit, and have not upgraded or changed my CCL installation in any way
during that time frame. My CCL version is 1.4-r13122. The only thing I can
think of that might changed on my system are security updates from
Microsoft. I have tried changing network settings, and disabling the
firewall, and nothing seems to help.

The reason I ask is because several months ago I
ported ccl::%get-ip-interfaces to CFFI. At the time, that implementation
worked perfectly on 5 different CL implementations. Now it returns nil in
all of them in Windows. I have not made any changes to the ip-interfaces
code during that time. Everything still works fine on other operating
systems.

Any ideas would be appreciated. Thanks.

-- 
Elliott Slaughter

"Don't worry about what anybody else is going to do. The best way to predict
the future is to invent it." - Alan Kay
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.clozure.com/pipermail/openmcl-devel/attachments/20100718/66689f22/attachment.html>


More information about the Openmcl-devel mailing list