[Openmcl-devel] Using Clozure CL with GNU Emacs and SLIME

Adam Getchell adam.getchell at gmail.com
Wed Mar 24 22:02:17 UTC 2010


On Wed, Mar 24, 2010 at 2:54 PM, Stas Boukarev <stassats at gmail.com> wrote:

Thanks for the help.


> Ununistall slime provided by debian:
> apt-get --purge remove slime cl-swank
>

I didn't install slime by debian:

adam at ubuntu:~/ccl$ sudo apt-get --purge remove slime cl-swank
[sudo] password for adam:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package slime is not installed, so not removed
Package cl-swank is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

>
> P.S. This question belongs to slime-devel mailing list.
>

Thanks, I just subscribed to that list.

> (slime-setup)
And you most probably want (slime-setup '(slime-fancy)) here.

Thanks, I've tried that before too, that gives:

Warning (initialization): An error occurred while loading
`/home/adam/.emacs':

error: Keyword argument (slime-fancy) not one of (:autodoc :typeout-frame
:highlight-edits)

To ensure normal operation, you should investigate and remove the
cause of the error in your initialization file.  Start Emacs with
the `--debug-init' option to view a complete error backtrace.

--
> With Best Regards, Stas.
>

Thanks again!

Adam Getchell
-- 
"Invincibility is in oneself, vulnerability in the opponent." -- Sun Tzu
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.clozure.com/pipermail/openmcl-devel/attachments/20100324/25f0b250/attachment.html>


More information about the Openmcl-devel mailing list