[Openmcl-devel] MCL 5.1 problems on OS X 10.5.8 on a G5

Alexander Repenning ralex at cs.colorado.edu
Sat Dec 17 04:46:25 UTC 2011


On Dec 16, 2011, at 9:09 PM, Toomas Altosaar wrote:

> Alex,
> 
> Is the G5 a dual-CPU?

yes it is, Thanks so much Toomas!



Alex

> 
> If so, it will need the revised pmcl-OSX-kernel - otherwise the vbl related crashes will occur at some nondescript time in the future.
> 
> The patched pmcl-OSX-kernel creation date is June 25, 2005. I am sending it to you directly in another mail.
> 
> I have noted another less severe problem when running code from 10.4 in 10.5: with OpenGL the color of text may turn black when calls to a simple sequence of three OpenGL fn are made:
> 
> glColor3f
> Glrasterfpos3f
> glprint
> 
> In 10.4 this controls the color well, but in 10.5.x color control seems flaky as the color of the rendered text may easily turn black (still visible, but then the background needs to be something other than black).
> 
> But that is another issue.
> 
> Toomas
> 
> 
> At 18:21 -0600 16.12.2011, openmcl-devel-request at clozure.com wrote:
>> We are getting some non descriptive errors when trying to run an MCL 5.1 application running fine on a G4 MacMini on OS X 10.4 on a G5 with OS X 10.5.8. I seem to vaguely remember some strange old problem when moving to a G5 many many years ago. Does anybody remember potential issues of MCL 5.1 running on G5s and perhaps even having some kind of patch?
>> 
>> Alex

Prof. Alexander Repenning

University of Colorado
Computer Science Department
Boulder, CO 80309-430

vCard: http://www.cs.colorado.edu/~ralex/AlexanderRepenning.vcf


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.clozure.com/pipermail/openmcl-devel/attachments/20111216/7da1929e/attachment.html>


More information about the Openmcl-devel mailing list