[Openmcl-devel] Last version for darwin PPC on mac osx 10.4?

R. Matthew Emerson rme at clozure.com
Sat Jan 29 21:10:26 UTC 2011


On Jan 29, 2011, at 3:40 PM, Willem Rein Oudshoorn wrote:

> I have some problems getting a multithreading common lisp implementation 
> to work on a powerpc macosx laptop.
> 
> It seems that the recent versions of ccl need macosx version 10.5 but
> I have 10.4.
> 
> Can anyone suggest a good version of ccl to try?

The Clozure CL 1.4 release will run on Mac OS X 10.4.

Please see:
http://trac.clozure.com/ccl/wiki/ReleaseNotes/1.4

There's been a lot of work done on the lisp during the 15 or so months that have gone by since 1.4 was released, so if you run into bugs, "upgrade to the current release" is probably going to be the advice you'll get.

In case non-financial reasons are keeping you from upgrading to Mac OS X 10.5, I will mention that you can pay Clozure Associates (via support incidents or some custom arrangement) to fix bugs in whatever release of CCL that you want.

Good luck.




More information about the Openmcl-devel mailing list