[Openmcl-devel] Mac cocoa build problem

R. Matthew Emerson rme at clozure.com
Wed Nov 2 23:19:57 UTC 2011


On Nov 2, 2011, at 6:31 PM, Jason Goth wrote:

> I installed Clozure CL on Mac OS X 10.5 and it works fine from the command line or Emacs/Slime.  However, when I try to build the IDE, I get this error:
> 
> ? (require :cocoa-application)
> > Error: ObjC class NSOrthography not found
> > While executing: LOOKUP-OBJC-CLASS, in process listener(1).
> 
> I can use Emacs/Slime, so this isn't a huge problem - but I would like to try the IDE.

The Cocoa-based IDE requires Mac OS X 10.6 Snow Leopard or later;
the command-line lisp still works on 10.5.

This requirement is mentioned at
http://trac.clozure.com/ccl/wiki/ReleaseNotes/1.7, which is
linked from http://ccl.clozure.com/download.html.  That's
perhaps not the most prominent place, I admit.

> Also, I'm new to the Clozure CL world, so if this isn't appropriately forum for this kind of question - please let me know.

You're in exactly the right place;  welcome.




More information about the Openmcl-devel mailing list