[Openmcl-devel] CCL on Windows

Elliott Slaughter elliottslaughter at gmail.com
Mon Oct 1 18:28:53 UTC 2012


On Mon, Oct 1, 2012 at 11:12 AM, Ron Garret <ron at flownet.com> wrote:

> I'm trying to help someone with a CCL project that they have to deliver on
> Windows, so I held my nose, fired up Parallels, and downloaded
> ccl-1.8-windowsx86.zip.  I fired it up, it briefly flashed a window on the
> screen which promptly vanished without a trace.
>
> Ah, I said to myself, now I remember why I don't use Windows.
>
> But I really would like to be able to help people who want to run CCL on
> Windows, so I'm kind of morbidly curious about how one goes about debugging
> problems like this.  When it comes to Windows, I am completely at sea.  I
> have never done any Windows development.  I have never used Windows for
> more than an hour or so at a time (which is about all I can take).  I'm at
> a conceptual loss, a complete and utter newbie.  How do you even get
> started when you don't have a shell?


You need to launch a shell first, then run commands inside it. Windows
programs are not abstracted from the shell, so each program will create its
own shell (if not run from an existing shell), which will then
(inconveniently) close immediately when the program finishes (or crashes).
Try to find Command Prompt in your list of programs. Alternatively, type
Windows-R (or Super-R, if you think in Emacs keys) and type cmd.exe and hit
enter.

Alternatively, use Cygwin or MSYS/MinGW. Many people I know can't actually
stand using the DOS command prompt anyway. Just be careful compiling C
programs under Cygwin because then they won't run on computers without
Cygwin installed.

http://www.cygwin.com/
http://www.mingw.org/wiki/Getting_Started

That is not a rhetorical question by the way.  How do I run SVN?


Cygwin (above) also conveniently has a package manager which can install
SVN for you. Or from Apache:

http://subversion.apache.org/packages.html#windows

How do I figure out what version of Windows I'm running?  How can I tell if
> I'm running 32 or 64 bit?  I know it's some ancient version of XP running
> under Parallels.


Find the "My Computer" icon, right click, and go to properties.

Alternatively, if you installed Cygwin, then "uname -a" should do.

Is CCL even expected to work?
>

CCL worked the last time I checked.

OMG, Windows is truly hellish.  I just tried to find a Windows binary SVN
> installer.  After several blind alleys I finally found the Apache SVN site
> which had half a dozen choices of binaries maintained by volunteers.  I
> picked one at random, and it crashed IE.  I tried Chrome.  It didn't work
> (it just gives me an hourglass no matter what I do -- even Settings won't
> come up).  Tried FireFox.  It worked, got a SVN binary installer package,
> ran it, it worked.  But the only thing it seems to have installed is
> documentation and license files.  There's no hint of a SVN executable
> anywhere.  Finally found the executable (I guess they hide it as a sort of
> filter to insure that you can't run it unless you have a certain minimal
> level of technical expertise), and it does the same flashy-crashy thing as
> CCL.


See launching cmd.exe, above.


> How does anyone put up with this shit?  (Now THAT is a rhetorical
> question.)
>

See Cygwin, above.

Anyway, if someone could point me in the right direction I would be most
> grateful.
>

Hope that helps.

rg
>
> _______________________________________________
> Openmcl-devel mailing list
> Openmcl-devel at clozure.com
> http://clozure.com/mailman/listinfo/openmcl-devel
>



-- 
Elliott Slaughter

"Don't worry about what anybody else is going to do. The best way to
predict the future is to invent it." - Alan Kay
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.clozure.com/pipermail/openmcl-devel/attachments/20121001/69fdefa5/attachment.html>


More information about the Openmcl-devel mailing list