[Openmcl-devel] Building from CVS

David Steuber david at david-steuber.com
Tue Apr 5 08:49:49 PDT 2005


Maybe I'm doing something stupid, but I've been using the following 
shell script to build OpenMCL when I do a cvs up:

david at interloper:~/usr/src/ccl-dev/ccl
$ cat build-openmcl.sh

cd lisp-kernel/darwin/
make clean
cd -

./dppccl -e "(progn \
                (xload-level-0 :force) \
                (compile-ccl t) \

echo "(save-application \"dppccl.image\")" | ./dppccl ppc-boot.image

This has been working fine until I tried it today (first time since 
just after 0.14.3 was released).  The repository I'm using is:

david at interloper:~/usr/src/ccl-dev/ccl
$ cat CVS/Repository

There are two seperate problems.  When I used the script, the new 
dppccl went straight into the kernel debugger when it started:

Unhandled exception 11 at 0x00004280, context->regs at #xbffff608
Read operation to unmapped address 0x6a260006
  In foreign code at address 0x00004280
? for help
[16404] OpenMCL kernel debugger:

I quit out of that because I don't know how to do anything useful with 
the kernel debugger.  I figured perhaps the new Lisp image was expected 
to be different, so I restored the old dppccl and tried to just compile 
the new Lisp image first.  This also failed:

;Compiling "/Users/david/usr/src/ccl-dev/ccl/level-0/l0-symbol.lisp"...
;Compiling "/Users/david/usr/src/ccl-dev/ccl/level-0/l0-utils.lisp"...
;Compiling "/Users/david/usr/src/ccl-dev/ccl/level-0/nfasload.lisp"...
 > Error in process listener(1): Unknown PPC opcode: LDR
 > While executing: PPC-LAP-INSTRUCTION
 > Type :GO to continue, :POP to abort.
 > If continued: Skip evaluation of (progn                (xload-level-0 
:force)                (compile-ccl t)                (quit))
Type :? for other options.
1 > :pop
Welcome to OpenMCL Version (Beta: Darwin) 0.14.3!
? (quit)

Maybe I simply checked out a broken file from CVS.  If not, how do I 
bootstrap to the current bleeding edge?

I can just hang back and work with 0.14.3 but I figured that by working 
with bleeding edge I could also be a tester in the event I somehow 
exercise a lesser used branch of code.  I can also try going back to 
CVS and updating from each checkin since 0.14.3 was released.  I think 
that still leaves a bootstrapping problem though.  How do you normally 
deal with this issue?

Oh, I'm running OS X 10.3.8 on a G4 with the gcc compiler from Xcode 1.5

$ gcc --version
gcc (GCC) 3.3 20030304 (Apple Computer, Inc. build 1666)

More information about the Openmcl-devel mailing list