[Openmcl-devel] Re: Status of Cocoa under Tiger?

Tord Kallqvist Romstad romstad at math.uio.no
Fri May 13 01:35:53 PDT 2005

Dan Knapp <dankna at accela.net> writes:

> > The Cocoa demo seems to work correctly in 050511 running in OS X 10.4,
> > but I have not been able to use Bosco to build Cocoa applications in
> > 10.4.  The simple cocoa example application delivered with Bosco
> > compiles without any error messages, but crashes instantly at startup:
> >
> >> Error: value #<A Dead Mac Pointer> is not of the expected type MACPTR.
> >> While executing: CCL::OBJC-SUBCLASS-P
>    There seem to be a number of ways to get that - I was messing
> with that last month, and have gotten that same error under 10.3,
> both with Bosco and with any other saved Lisp image that has the
> Cocoa stuff preloaded.  I didn't find a solution, unfortunately.

In 10.3, at least very simple Bosco Cocoa applications worked.  I had
some problems with more complicated applications, but I was always
able to solve them by moving the problematic parts of the code to
.dfsl files which were loaded when the application had finished

Tord Romstad

More information about the Openmcl-devel mailing list