[Openmcl-devel] Missing header(s) for OpenGL FFI?

Phil pbpublist at comcast.net
Mon Aug 14 10:56:22 PDT 2006

On Aug 13, 2006, at 5:27 AM, Gary Byers wrote:

> What I expected is for the problem that you mentioned earlier to have
> nothing to do with what interfaces you've been using.

Agreed... I was just confirming that the error reporting error had  
been addressed.

> You can probably get the WebKit example to force all classes to be
> processed by calling RESET-OBJC-CLASS-COUNT just before the call to
> "ccl:examples;webkit.lisp".  You may run into other problems,
> and it's unfortunately the case that trying to load an add-on
> framework on top of Cocoa basically doesn't work reliably in 1.0;
> if it seems to, that's largely an accident.

At this point, I realized that I have been asking you to repeat  
yourself so I went back through the various Cocoa threads and tried  
to roll up what you've told me and others get the best support for  
Tiger and additional interfaces.  After some preliminary playing  
around, I've got something which appears to be working and wanted  
your thoughts.  As FFI files are just wrappers around the C headers,  
and many of the higher-level Cocoa Frameworks depend on the lower  
levels, it appears that much of the effort to generate FFI files per  
cocoa framework is duplication (i.e. virtually every framework I've  
looked at resulted in a 4+ meg FFI file which appears to be mostly  
common includes.) So I tried creating a single FFI file for every  
cocoa framework I could think of which resulted in an 11 meg (so far)  
FFI file and when processed into CDB it's only about 2x the size of  
the base Cocoa CDB files.  Then I created a function to load an  
arbitrary framework using the webkit template and your previous  
suggestions/fixes.  The results so far are encouraging but wanted to  
get your take on any potential pitfalls with this approach.

More information about the Openmcl-devel mailing list