[Openmcl-devel] Annoying, Deprecated #\, Macros

Brent Fulgham bfulg at pacbell.net
Sun Oct 8 21:30:19 PDT 2006

Some time ago (http://www.clozure.com/pipermail/openmcl-devel/2005- 
November/003085.html), Gary discussed the rationale behind removing  
the "#," macro.  This weekend, in trying to get Maxima to build under  
OpenMCL 1.0, I ran into the following form, which fails to read:

(from Maxima's "src/transq.lisp" file):
(defun gen-name ( &optional k &aux (n '#,(*array nil 'fixnum 1)))
   (store (arraycall fixnum n 0) (f1+ (arraycall fixnum n 0)))
   (and k (store (arraycall fixnum n 0) k))
   (implode (append (exploden *infile-name-key*)
                   (exploden '|-tr-gen-|)
                   (exploden (arraycall fixnum n 0)))))

I tried various forms of:

#+(and :maclisp (not :openmcl))



and eventually just commented the thing out.

While this function is not needed for Maxima, it seems odd that I  
can't get OpenMCL to ignore the function entirely so that the sources  
can retain their cross-lisp system compatibility.  Any idea what I'm  
doing wrong?



More information about the Openmcl-devel mailing list