[Openmcl-devel] how to use quicktime

Alexander Repenning ralex at cs.colorado.edu
Mon Dec 1 01:15:47 UTC 2008


Just wondering if somebody has some ideas on how to use QuickTime from  
CCL (1.2). Here are some ways that do NOT work:

1) using QuickTime framework:

I can access the quicktime functions from PPC CCL

(ccl:open-shared-library "/System/Library/Frameworks/ 
QuickTime.framework/QuickTime")

using QT functions appears to work. But not so in Intel-Mac CCL

Error: Error opening shared library "/System/Library/Frameworks/ 
QuickTime.framework/QuickTime": dlopen(/System/Library/Frameworks/ 
QuickTime.framework/QuickTime, 10): no suitable image found. Did find:
 > /System/Library/Frameworks/QuickTime.framework/QuickTime: no  
matching architecture in universal wrapper

OK, I guess this not 64bit compatible.

2) using NS movie

ns:ns-movie is bound: #<OBJC:OBJC-CLASS NS:NS-MOVIE (#xA0894754)>

so I think this MAY work but I get the warning: Legacy Document,  
Important: This class is deprecated. Use QTMovie instead.

I rather not use this then.

3) using QTMovie

There is not obvious evidence of an existing class called QTMovie in  
CCL.... hmmm

4) using QTkit

(ccl:open-shared-library "/System/Library/Frameworks/QTKit.framework/ 
QTKit")

succeeds but how does one create the main classes, e.g., QTMovie and  
QTMovieView? I assume this would be the recommended route to go.

Has anybody managed to get some QuickTime code working?

Alex



Prof. Alexander Repenning

University of Colorado
Computer Science Department
Boulder, CO 80309-430

vCard: http://www.cs.colorado.edu/~ralex/AlexanderRepenning.vcf


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.clozure.com/pipermail/openmcl-devel/attachments/20081130/10893fd9/attachment.html>


More information about the Openmcl-devel mailing list