[Openmcl-devel] CCL on Linux x86: no output on launch

R. Matthew Emerson rme at clozure.com
Mon Jan 12 19:34:17 PST 2009

On Jan 12, 2009, at 6:58 PM, Scott Bell wrote:

> On 12-Jan-09, at 3:59 PM, R. Matthew Emerson wrote:
>> The following commands should get you to a working state:
>> % cd /path/to/ccl
>> % svn up
>> % svn revert lx86cl
>> % svn revert lx86cl.image
>> % ./lx86cl
>> If that works, do
>> ? (rebuild-ccl :full t)
>> and that will bring you up-to-date.
> I performed the above, but there was no change. This isn't surprising
> since I was experiencing this on a clean checkout from SVN.
> This has never worked for me before, at least not on this machine,
> which is a standard Fedora Core 8 Amazon EC2 image running on
> Xen.

I tried to run the lisp on an EC2 image myself.

What seems to happen is that the lisp kernel starts up, maps in the  
heap image, and starts running lisp code, which pretty much  
immediately tries to allocate memory by taking a trap (int $0xc5 on  
x86 systems).

For some reason, instead of generating a SIGSEGV like we expect, the  
system just sort of sits there, dumbly staring at the alloc_trap in a  
puzzled manner.

I don't know if this a symptom of running on Xen or whether there is  
some other peculiarity of Amazon's EC2 set-up.  I have run Clozure CL  
on a a Linux Xen instance before, though it was a 64-bit version.

More information about the Openmcl-devel mailing list