[Openmcl-devel] To send or not to send

Alexander Repenning ralex at cs.colorado.edu
Fri May 29 10:18:31 PDT 2009

this is somewhat subjective, I guess. I  do not mind "send" being  
depreciated but I do share the concern about readability when there  
are many parameters, e.g.,

(#/compositeToPoint:fromRect:operation:fraction: Image Point Rect Op  
Fraction)  does look a bit clumsy, in terms of readability, and less  
CL than perhaps

(#/compositeToPoint: Image Point :fromRect Rect :operation  
Op :fraction Fraction)


On May 29, 2009, at 10:55 AM, Ron Garret wrote:

> I was disappointed by this because I kinda sorta like the send  
> syntax better than the straight ObjC syntax.  There are times when:
> (send foo ns::snoz :baz bar :bing boff)
> just feels cleaner than
> (#/snozBazBing: foo bar boff)
> especially when there are a lot of arguments.  Why is send being  
> deprecated?

Prof. Alexander Repenning

University of Colorado
Computer Science Department
Boulder, CO 80309-430

vCard: http://www.cs.colorado.edu/~ralex/AlexanderRepenning.vcf

More information about the Openmcl-devel mailing list