[Openmcl-devel] [hunchentoot-devel] Anyone running Hunchentoot on an OpenBSD server? - final report

Bill St. Clair billstclair at gmail.com
Mon Nov 16 01:08:55 PST 2009


Thanks for trying. So we know exactly what you were trying, please
send the output of "svn info" in your "ccl" directory (or the "svn co
..." command you used to check it out, if you've deleted the directory

Clozure folks, looks like there's at least a little work to do to make
CCL work in OpenBSD. Whether it's worth the effort probably depends on
whether someone is willing to pay for it.


On Sun, Nov 15, 2009 at 9:18 PM, Jeff Cunningham
<j.k.cunningham at comcast.net> wrote:
> Bill,
> Whoops. Got it. They don't work either. Same errors. Then I tried to build
> the 32-bit kernel:
> jeffrey_cunningham at scallop:~/clozure/ccl/lisp-kernel/freebsdx8632$ make
> m4 -DFREEBSD -DX86 -DX8632 -DHAVE_TLS -I../ ../pad.s | as  --32 -o pad.o
> m4 -DFREEBSD -DX86 -DX8632 -DHAVE_TLS -I../ ../x86-spjump32.s | as  --32 -o
> x86-spjump32.o
> m4 -DFREEBSD -DX86 -DX8632 -DHAVE_TLS -I../ ../x86-spentry32.s | as  --32 -o
> x86-spentry32.o
> m4 -DFREEBSD -DX86 -DX8632 -DHAVE_TLS -I../ ../x86-subprims32.s | as  --32
> -o x86-subprims32.o
> cc -c ../pmcl-kernel.c -DFREEBSD -D_REENTRANT -DX86 -DX8632 -D_GNU_SOURCE
> -DHAVE_TLS -g  -m32 -o pmcl-kernel.o
> In file included from ../area.h:23,
>                  from ../kernel-globals.h:20,
>                  from ../lisp.h:66,
>                  from ../pmcl-kernel.c:25:
> ../memprotect.h:32:22: ucontext.h: No such file or directory
> In file included from ../x86-exceptions.h:62,
>                  from ../lisp-exceptions.h:150,
>                  from ../gc.h:23,
>                  from ../pmcl-kernel.c:27:
> ../freebsdx8632/fpu.h:70: error: syntax error before numeric constant
> ../pmcl-kernel.c:100:18: elf.h: No such file or directory
> ../pmcl-kernel.c:110:18: fenv.h: No such file or directory
> *** Error code 1
> Stop in /home/jeffrey_cunningham/clozure/ccl/lisp-kernel/freebsdx8632 (line
> 92 of /usr/share/mk/sys.mk).
> Looks like the kernel headers aren't present on this system. Sigh. It hasn't
> been a good day.
> Thanks though. I think I'll have a look at Clozure at home anyway.
> --Jeff
> Bill St. Clair wrote:
> Jeff,
> The FreeBSD binaries are named fx86cl and fx86cl64:
> cd .../ccl
> ./fx86cl
> or:
> cd .../ccl
> ./fx86cl64
> I had to rebuild the kernel from sources to get it to work in my
> FreeBSD system. You may have to do that:
> cd .../ccl/lisp-kernel/freebsdx8632
> make
> cd .../ccl/lisp-kernel/freebsdx8664
> make
> Then try the two binaries again.
> -Bill
> On Sun, Nov 15, 2009 at 8:07 PM, Jeff Cunningham
> <j.k.cunningham at comcast.net> wrote:
> Hi Bill,
> We should probably take this off list, its gone off topic (and I just posted
> to this effect on list and not to you by mistake).
> I just grabbed latest snapshot through subversion and tried the binary and
> it failed, so apparently it isn't compatible with OpenBSD.  I tried both the
> lx86cl64 and lx86cl versions (can't tell if this remote machine is 64-bit or
> not, it doesn't have /proc/cpu-info mounted and that's the only way I know
> to find out). I don't have root priviledges so there's not much else I can
> try that I know of. Is there a way to build it from scratch? Or do you have
> to start with the binary?
> Regards,
> Jeff

More information about the Openmcl-devel mailing list