[Openmcl-devel] re ...the sky is falling

wws2 new ww.s2 at ukonline.co.uk
Fri Apr 9 00:38:09 PDT 2010

Part of my "sky is falling problem" appears related to the 'foreign' characters--such as the one for copyright ©--that MCL allowed but ccl does not.  So a file with that copyright symbol will throw into Alt-Consol when it is opened via meta-dot on a definition within that file.  This could probably be 'solved' by changing the default file encoding, but as I want to use the same source file between multiple platforms (and edit in MCL) my solution is to replace the copyright characters with the three characters "(c)".  

If that replacement is made (in MCL) and the file opened in CCL via meta-dot, it will still fail with the normal message about an array reference being out of bounds.  However if the code is then 're-executed' in CCL and the file closed (without saving),  Meta-dot works.  So there is something in that 'store-my-position' mechanism during compilation and saving definitions that is affected by foreign characters.

More information about the Openmcl-devel mailing list