[Openmcl-devel] slime and unicode: Lisp connection closed unexpectedly: connection broken by remote peer

Tobias C. Rittweiler tcr at freebits.de
Mon Mar 8 15:08:54 UTC 2010


Leo <sdl.web at gmail.com> writes:

> Hello Gary,
>
> Sorry for the delay.
>
> On 2010-03-06 00:33 +0000, Gary Byers wrote:
>> I don't ordinarily use SLIME, but for what it's worth I tried
>> following the Wiki's instructions with an Emacs that identifies itself
>> as 23.1.1 (Fedora's 1.23.1-18.fc12 package) and today's CVS SLIME on
>> x86-64 Fedora and up-to-date trunk CCL and everything behaved as
>> expected.  That's not quite what you're running, but it's likely
>> pretty close.
>>
>> Does everything work for you except UTF-8 encoding ?  Is there
>> anything in the *inferior-lisp* buffer that might shed light on
>> the problem ?  Did you build the Emacs yourself, or download it
>> from somewhere, or ... ?
>
> I guess it may be a bug in slime. For example, when I run 'ccl64 -K
> utf-8' in terminal and connect to it from emacs:
>
>   (defparameter language '日本語)
>
> will disconnect slime right away.
>
> With inferior lisp, however, it seems to work as noted in ccl wiki.
>
> Everything else works for me.

Try HEAD and paste the debugging output you get in *inferior-lisp*.

  -T.




More information about the Openmcl-devel mailing list