[Openmcl-devel] build issue

Antony lisp.linux at gmail.com
Fri Jan 7 07:01:25 PST 2011


I ran into a issue and logged  a bug
I thought this may be because I have not built CCL when I updated, so 
tried building.

The build is failing.
I am using the mingw stuff from cygwin.
CCL is from

Here is what happens when I try to build
Welcome to Clozure Common Lisp Version 1.7-dev-r14406M-trunk  
(WindowsX8664                                        )!
? (rebuild-ccl :full t)
Rebuilding Clozure Common Lisp using Version 1.7-dev-r14406M-trunk  
(Window                                        sX8664)
;Building lisp-kernel ...
 > Error: Error(s) during kernel compilation.
 >        make: Entering directory 
 >        x86_64-w64-mingw32-gcc -Wl,--image-base=0x10000 
-Wl,-script=pei-x86-64.x -m64 -g    -o ../../wx86cl64.exe  pad.o 
x86-spjump64.o x86-spentry64.o x86-subprims64.o pmcl-kernel.o 
gc-common.o x86-gc.o bits.o  x86-exceptions.o image.o thread_manager.o 
lisp-debug.o memory.o windows-calls.o x86-asmutils64.o  imports.o 
lispdcmd.o plprint.o plsym.o xlbt.o x86_print.o -lpsapi -lws2_32
 >        pmcl-kernel.o: In function `remap_spjump':
undefined reference to `spjump_start'
 >        pmcl-kernel.o: In function `check_x86_cpu':
undefined reference to `cpuid'


More information about the Openmcl-devel mailing list