[Openmcl-devel] Does Clozure CL64 run on Mac OS X Lion?

Gary Byers gb at clozure.com
Sat Jul 23 23:07:30 PDT 2011

It's pretty obvious what version of CCL you're using from context, but
when reporting something like this it's generally a good habit to mention
that information, even if it doesn't seem obviously relevant.

I assume that you're running CCL 1.6, which was released several months
before Apple introduced this bug.  (This is pretty clearly a bug; there's
another incompatible change to the Lion ObjC runtime that's a bit of a
surprise but is intentional and isn't a bad idea:  "Apple Invents Tagging!").

We worked around this in the trunk (mostly) in r14821 and the relevant changes
are in the 1.7 prerelease; we hope that 1.7 final will be released in the next
few days.  We haven't backported the changes to 1.6; I'm not sure that doing
so makes a lot of sense at this point.

On Sat, 23 Jul 2011, Eric Swenson wrote:

> I tried running both the 64-bit and 32-bit IDEs on Mac OS X Lion and
> neither came up, giving this error instead:
>> Error: value #<A Foreign Pointer #x7FFF781EC8A0> is not of the expected type OBJC:OBJC-OBJECT.
>> While executing: (:INTERNAL GUI::|+[LispApplicationDelegate initialize]|), in process Initial(0).
>> Type :POP to abort, :R for a list of available restarts.
>> Type :? for other options.
> 1 >
> Is this a known problem?  Anything I can do about it?
> Thanks.  -- Eric
> _______________________________________________
> Openmcl-devel mailing list
> Openmcl-devel at clozure.com
> http://clozure.com/mailman/listinfo/openmcl-devel

More information about the Openmcl-devel mailing list