[Openmcl-devel] Incompatibility with Xcode 4?

Raffael Cavallaro raffaelcavallaro at mac.com
Mon Mar 14 08:54:50 PDT 2011

I've just tried to rebuild ccl and I run into an issue building the lisp kernel.

Here's the error I'm seeing:

> Error: Error(s) during kernel compilation.
>        gm4 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -I../ ../x86-spjump64.s | as -arch x86_64 -g -o x86-spjump64.o
>        gm4 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -I../ ../x86-spentry64.s | as -arch x86_64 -g -o x86-spentry64.o
>        gm4 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -I../ ../x86-subprims64.s | as -arch x86_64 -g -o x86-subprims64.o
>        gm4 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -I../ ../imports.s | as -arch x86_64 -g -o imports.o
>        gcc-4.0 -include ../platform-darwinx8664.h -c ../pmcl-kernel.c -arch x86_64 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -DSVN_REVISION=14674 -g -O2 -Wno-format -mdynamic-no-pic -mmacosx-version-min=10.5 -isysroot /Developer/SDKs/MacOSX10.5.sdk -o pmcl-kernel.o
>        gcc-4.0 -include ../platform-darwinx8664.h -c ../gc-common.c -arch x86_64 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -DSVN_REVISION=14674 -g -O2 -Wno-format -mdynamic-no-pic -mmacosx-version-min=10.5 -isysroot /Developer/SDKs/MacOSX10.5.sdk -o gc-common.o
>        gcc-4.0 -include ../platform-darwinx8664.h -c ../x86-gc.c -arch x86_64 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -DSVN_REVISION=14674 -g -O2 -Wno-format -mdynamic-no-pic -mmacosx-version-min=10.5 -isysroot /Developer/SDKs/MacOSX10.5.sdk -o x86-gc.o
>        In file included from <command line>:1:
>        ./../platform-darwinx8664.h:24:24: error: no include path in which to search for sys/signal.hIn file included from <command line>:1
>        ./../platform-darwinx8664.h:25:26: error: no include path in which to search for sys/ucontext.h
>        :
>        ./../platform-darwinx8664.h:24:24: error: no include path in which to search for sys/signal.h

and hundreds more such "no include path in which to search for ..." errors.

I can see that the mentioned headers are indeed present in /usr/include/ so I don't know why I'm seeing this error.

As background, I noticed when I installed Xcode 4 that there was no longer an option to install Mac OS X 10.4 support, so I wonder if this is causing a problem with the kernel build?

In any event, going forward,  even if it turns out this is not an issue with the absent 10.4 support, you may want to remove that dependency since the overwhelming majority of users will be using the now current version of Xcode, which is 4, and which, if I am not mistaken, no longer provides the option for 10.4 support.

warmest regards,


Raffael Cavallaro
raffaelcavallaro at me.com

More information about the Openmcl-devel mailing list