[Openmcl-devel] Codesigning a CCL based applicaiton

R. Matthew Emerson rme at clozure.com
Wed Aug 29 18:36:35 PDT 2012

On Aug 29, 2012, at 5:57 PM, Michael Minerva <minerva at agentsheets.com> wrote:

> Now that bad news, the application is no longer executable, I suppose this was not to surprising since I had not done anything to add the heap image.  Next I went ahead and copied all the applicable ccl files into MyApp.app/Contents/Resources/ccl/ including dx86cl64.image.  This still did not work but I figured this was likely because of your next point about the names matching so I tried both changing the name of the image to MyApp.image (leaving the kernel as MyApp) and also tried changing the kernel dx86cl64 (leaving the heap image as dx86cl64.image).  Still none of these solved the problem.  
> Now after trying all this I noticed that the file located inside MyApp.app/Contents/MacOS was not am executable file (it was a document and would open the binary in a text editor if I double clicked it), it now seems that this may be my main source of trouble.  

Well, chmod +x MyApp.app/Contents/MacOS/MyApp would solve that, wouldn't it?

The other thing to check is the value of the CFBundleExecutable key in the bundle's Info.plist file.  It should match the name of the lisp kernel binary in MyApp.app/Contents/MacOS.

More information about the Openmcl-devel mailing list