[Openmcl-devel] Clozure CL on Android

Gary Byers gb at clozure.com
Tue Jan 31 17:51:37 PST 2012

On Wed, 1 Feb 2012, Roman Kovalev wrote:

> CCL is now working on my Android and I have some questions.
> 1. I transferred Android-headers to the device and tried to run rebuild-ccl:
> Error: File #P"ccl:lib;systems.lisp.newest" not found.
> Sources needed?

Yes, and getting them onto an Android device is sometimes a little
awkaward.  (I've been doing stuff involving mounting the device as a
USB disk on a Mac (a Windows or Linux box should work as well), doing
an "svn checkout" and periodic "svn updates" to a CCL directory on the
mounted disk, then unmounting it and using symbolic links from the
subdirectories /mnt/sdcard/ccl (where the svn tree is) to subdirectories
of /data/local/ccl.

Anyway: REBUILD-CCL compiles sources to FASLs and builds a heap image out
of those FASLs, and it's not going to be able to do much if the sources
aren't there.

> 2. I ran the following code.
> (do-external-symbols (s (find-package "ARM-ANDROID")) (print s))
> And the output list is empty. Situation will change after a rebuilding CCL?

Yes. More precisely, symbols that're read by #$/#_ are interned in that

If you type


you should get a small integer returned (I think that the value of that
integer is 21351 or something similar); if you get an error instead, that
means that the "android-headers" directory is missing or something.  If you
can get the reader macro to return a value, that package will have at least
one symbol in it.

None of this (but the name of the package) is Android-specific.

> 3. Is it possible to using android's graphic and other (java)libraries
> with ccl now?

No, but that's obiously desirable.

> 4. In that compiles aarmc as a result?

I don't understand.

More information about the Openmcl-devel mailing list