[Openmcl-devel] process-interrupt and locks leading to deadlocks

David L. Rager ragerdl at gmail.com
Wed Aug 14 21:04:34 UTC 2013


Hi,

Just a small comment from a spectator that hasn't worked with the
debugger in a while: IIRC correctly, you can figure out which lock
each thread is waiting on by interrupting it and looking at its stack
(from the backtrace, using :raw, etc).  So, if you can get to a
deadlock state _with_ interrupts enabled, I'd think you could debug
the situation.

David

On Tue, Aug 6, 2013 at 1:55 PM, Florian Dietz <Florian.Dietz2 at gmx.de> wrote:
> I have two threads, A and B. I am using process-interrupt to interrupt
> thread A. The interruption can only finish once thread B has also processed
> some information and waits on thread B via a semaphore. This can lead to a
> deadlock if A gets interrupted while holding a lock that is needed in B. I
> have tried to prevent this problem by encapsulating all locks with
> without-interrupts.
>
> Unfortunately, some processes seem to use implicit locks that I am not aware
> of. Is there an easy way to find out which functions could be at fault
> without manually looking up the definition of every function I am using?
> Also, could error-handling have something to do with this error?
> _______________________________________________
> Openmcl-devel mailing list
> Openmcl-devel at clozure.com
> http://clozure.com/mailman/listinfo/openmcl-devel



More information about the Openmcl-devel mailing list