[Openmcl-devel] CCL Issue with Lion

Michael Minerva minerva at agentsheets.com
Thu May 2 14:32:33 PDT 2013

We are experiencing another strange issue, this time it is related to Lion and Sandboxing.  We initially noticed the issue when we tried to test a sandboxed version of our app on Lion. Every time we would try and launch an NSOpenPanel, it would stall for about 10 seconds, nothing would come up and then the program would resume. The call to runModal returns without ever bringing up the window and there is no error in the console. In order to try and dissect this problem a little further, we downloaded a fresh copy of the release version of CCL and sandboxed both the 32bit and 64bit versions of CCL, when we fired up these apps on Lion and simply tried to open a file (command O or open… from the File menu) the same behavior we saw in our app occurs in the sandboxed CCL I.E. the File menu is highlighted and stalled for 10 seconds, no file chooser comes up and then it returns without ever showing the chooser.  We have also tried this same experiment with the most recent trunk of CCL and it exhibits the same behavior. 

A few Notes:
• This occurs only on Mountain Lion we have tested versions 10.7.2  and 10.7.5 and it occurs on both
• We have tested on Mountain Lion and Snow Leopard and this problem does not occur (even with the sandboxed versions)
• We have tried sandboxing with a valid certificate like this: codesign -s "Developer ID Application: AgentSheets, Inc."   -f --entitlements /Users/Mike/Desktop/AgentCubes\ 1.02-Lite/AgentCubes32bit.app/Contents/AgentCubes.entitlements /Users/Mike/ccldev15801/Clozure\ CL32.app 
• We have also tried sandboxing with no certificate like:  codesign -s  - -f --entitlements /Users/Mike/Desktop/AgentCubes\ 1.02-Lite/AgentCubes32bit.app/Contents/AgentCubes.entitlements /Users/Mike/ccldev15801/Clozure\ CL64.app 
• Both the code signed and non code signed sandboxed apps exhibit the issue
• We have examined the code signed app with spctl to verify that it is code signed with a valid certificate 

Here is a link to a sandboxed version of CCL 1.9 release:


When we open this version in Lion and goto File-> Open it exhibits the issue (no file chooser comes up and the File menu stalls blue for ~10 seconds).  Could anyone else running Lion verify that they see the same issue?  Anyone have any clues about what could be going on here?  

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.clozure.com/pipermail/openmcl-devel/attachments/20130502/53e56d12/attachment.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 2559 bytes
Desc: not available
URL: <https://lists.clozure.com/pipermail/openmcl-devel/attachments/20130502/53e56d12/attachment.bin>

More information about the Openmcl-devel mailing list