[Openmcl-devel] trying some ASuDF tests on Windows (was: Re: [asdf-devel] Volunteer for LispWorks testing?)

Dave Cooper david.cooper at genworks.com
Thu Sep 5 20:14:13 UTC 2013

Fare wrote:
> The test-bundle.script output suggests that, on Windows, there might
> be a bug in ccl:fasl-concatenate. Please create a reduced test, and
> open a bug against CCL if that is indeed the case, using
> http://trac.clozure.com/ccl/newticket

Ok, I went ahead and opened a CCL bug, which was (almost immediately)
reported as fixed in the subversion trunk and the ticket (#1109) was
closed. Then I built a CCL from the trunk (which is 1.10-dev), and indeed
this failure goes away when using 1.10-dev. See the results in the
2013-09-05 folder in the link below.

> The test-multiple.script failure reveals an error in run-program, that
> looks like it does a (cons "cmd" argument) instead of a (list "cmd"
> argument). Same failure in test-run-program.script.

I tried changing the code in uiop/run-program.lisp from:

  #+clozure (cons "cmd" (strcat "/c" command))


   #+clozure (list "cmd" (strcat "/c" command))

but still get some failures in test-run-program.script. Maybe they are
different failures.  See results below.


By the way, the run-program tests seem to use the command "ln" for testing
-- this command isn't there by default on Windows, is it?

The issue with ";" vs. ":" for path separator I'm not sure exactly where to
fix, so I leave that alone for the time being (anyone else care to jump on
it?) --- apparently that's not CCL-specific, but a general Windows asdf
testing issue?

On Wed, Sep 4, 2013 at 5:07 PM, Robert P. Goldman <rpgoldman at sift.info>wrote:

> Dave Cooper wrote:
> >
> > Hi Robert,
> >
> >  [also cc'ing this to asdf-devel in case anyone else has feedback]
> >
> > Ok, shifting gears a little bit here first...
> >
> > I'm trying a few test runs of the ASDF test suite on Windows. Platforms
> > on Windows which I have available to test right now are: Allegro CL
> > (several variations), and CCL.
> >
> > To prepare to run the tests on Windows, I installed cygwin and cygwin's
> > make. Then to run the tests, I do (for lack of having this more
> > automated so far):
> >
> > 1.  set ASDF_TEST_LISPS appropriately.
> >
> > 2. Edit run-tests.sh to point to appropriate Lisp executables.
> You actually shouldn't need to do that -- there is one environment
> variable for each of the executables, and you can set those, if the
> default values don't work for you.
> >
> > 3  Invoke "make test-all-no-upgrade" from the cygwin command shell.
> >
> > Let's try CCL first.  Here are the outputs:
> >
> >
> https://www.dropbox.com/sh/jc2cqwpkp06dupm/-vvd5gFwTk/cl/tests/asdf/output/2013-09-04/windows/ccl-1.9-f96-win-x86/ccl.text
> >
> > Summary: 42 out of 47 pass (5 failures).
> >
> > I can try to dive into these further, but I thought I would post the
> > results here first in case anything is obvious to anyone.
> >
> > Incidentally, I have been running ASDF in production with Allegro CL for
> > some time now (including asdf:monolithic-fasl-op) and it has been
> > working well.  There are some startup glitches for running ASDF tests on
> > Windows/Allegro right now. After the CCL issue is resolved I will return
> > to trying to get the tests to run for Allegro on Windows.
> That would be great.
> By the way, the bundle tests aren't working for me on a couple of other
> lisps.
> cheers,
> r

My Best,

Dave Cooper, Genworks Support
david.cooper at genworks.com, dave.genworks.com(skype)
USA: 248-327-3253(o), 1-248-330-2979(mobile)
UK: 0191 645 1699
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.clozure.com/pipermail/openmcl-devel/attachments/20130905/13ac18d6/attachment.html>

More information about the Openmcl-devel mailing list