[Openmcl-devel] WG: Clozure Lisp and cl-opengl on Windows 7

Andreas Thiele andreas at atp-media.de
Tue Sep 10 17:03:35 UTC 2013

Sorry, forgot to inform the list.


Von: Andreas Thiele [mailto:andreas at atp-media.de] 
Gesendet: Dienstag, 10. September 2013 15:25
An: 'Jason Aeschliman'
Betreff: AW: [Openmcl-devel] Clozure Lisp and cl-opengl on Windows 7




thanks for this hint. I tried things like this but it didn't work.


Meanwhile Bart Botta fixed cl-opengl. Now this works in context! Fine. Seems
not to be an CCL issue.


Thanks a lot




Von: Jason Aeschliman [mailto:j.aeschliman at gmail.com] 
Gesendet: Dienstag, 10. September 2013 15:07
An: Andreas Thiele
Cc:  <mailto:openmcl-devel at clozure.com> openmcl-devel at clozure.com
Betreff: Re: [Openmcl-devel] Clozure Lisp and cl-opengl on Windows 7


On OSX I use cl-glut for this:


(setf cl-opengl-bindings:*gl-get-proc-address* 'cl-glut:get-proc-address)





On Sep 10, 2013, at 2:15 AM, Andreas Thiele <andreas at atp-media.de> wrote:




I have problems running cl-opengl. I used quicklisp and load cl-opengl.


Here a probably simple error:


After trying


(gl:get* :version)


I get:


NIL is not of type (OR SYMBOL

                       FUNCTION), and can't be FUNCALLed or APPLYed

   [Condition of type TYPE-ERROR]



0: [RETRY] Retry SLIME REPL evaluation request.

1: [*ABORT] Return to SLIME's top level.

2: [ABORT-BREAK] Reset this thread

3: [ABORT] Kill this thread






  3: (SWANK::EVAL-REGION "(gl:get* :version)\n")


I obtain exactly the same error on CCL 1.9 32-bit and 64-bit. Looks like
something small or simple.


Any advice appreciated.


Best Regards

Andreas Thiele





Openmcl-devel mailing list
 <mailto:Openmcl-devel at clozure.com> Openmcl-devel at clozure.com


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.clozure.com/pipermail/openmcl-devel/attachments/20130910/c959396c/attachment.html>

More information about the Openmcl-devel mailing list