[Openmcl-devel] Stuck with a strange emacs / openmcl problem

Gary Byers gb at clozure.com
Thu Dec 4 06:57:32 UTC 2014


On 12/03/2014 03:32:34 PM, Fabrice Popineau wrote:
> Emacs 24.4 W32/W64
> 
> I'm trying to run Clozure Common Lisp under Emacs / Slime.
> Slime lauches CCL and starts the Swank server.
> When the process is started by Emacs, I get an error with this  
> backtrace :
> 
> ? ;Loading #P"c:/Home/.emacs.d/vendor/slime/swank-loader.lisp"...
> > Error: Le fournisseur de services demandé n’a pas pu être chargé ou
> initialisé.  (error #10106) during socket creation operation in socket
> > While executing: SOCKET-ERROR, in process listener(1).
> > Type :POP to abort, :R for a list of available restarts.
> > Type :? for other options.
> 1 > :b
>  (223996E8) : 0 (SOCKET-ERROR NIL "socket" 10106 NIL) 1133
>  (22399750) : 1 (MAKE-TCP-SOCKET :CONNECT :PASSIVE :LOCAL-PORT 0
> :LOCAL-HOST "127.0.0.1" :REUSE-ADDRESS T :BACKLOG 5) 429
>  (223997D8) : 2 (MAKE-SOCKET :CONNECT :PASSIVE :LOCAL-PORT 0  
> :LOCAL-HOST
> "127.0.0.1" :REUSE-ADDRESS T :BACKLOG 5) 965
> 

Google Translate says that an English translation of the error message  
is "The requested service provider could not be loaded or  
initialized",  I have no idea what (Winsock) service provider would be  
required to create a socket bound to the loopback address.

> The same thing works if I run OpenCL from the console.
> How the fact that the process is run from Emacs could
> result in an error from make-tcp-socket ?''

I assume that something in SLIME/SWANK is calling MAKE-TCP-SOCKET;   
even if I translate the error message into English I don't know what it  
means.

> Conflict with the winsock2 dll which is loaded by both process ?

I have no idea what that means, either.

> 
> I have tried many combinations of CCL and emacs :
> - Emacs 24.4 32 bits (GNU version)
> - Emacs 24.4 64 bits (my version)
> - OpenCL 64 bits (official 1.10 version)
> - OpenCL 64 bits (compiled by me with the same toolchain used to  
> compile
> Emacs)
> - OpenCL 32 bits
> 
> I couldn't find a working version. Any idea on how to hunt this ?


I searched via google for "winsock error 10106" and some of the results  
that I got
suggested that it was often a problem with Windows XP, but I have no  
idea what version of Windows you're running.

http://www.thinglink.org/wsaeproviderfailedinit.php seems to try to  
explain the error, but it also seems to be confused about what  
Hexadecimal means.

If you run CCL from the console,  do you get the same error when you  
call MAKE-SOCKET with the same arguments in the listener ?  If not,  
then that might suggest some problem with something in the SLIME code  
(but I don't think that's very likely and can't guess what that problem  
would be.)  I have even less of an idea how Emacs could be involved,  
and you seem to have installed many versions of Emacs without finding  
any evidence that that's relevant.

I suppose that it could be a CCL bug that no one else has noticed or  
reported, but I'd rather not actually run Windows to test that.

I won't insult you by asking if TCP networking is configured and  
working on this machine (unless, of course, you say that it isn't or  
that you're uncertain ...)


> 
> Best regards,
> 
> --
> Fabrice
> 

------quoted attachment------
> _______________________________________________
> Openmcl-devel mailing list
> Openmcl-devel at clozure.com
> https://lists.clozure.com/mailman/listinfo/openmcl-devel
> 



More information about the Openmcl-devel mailing list