[Openmcl-devel] run-program

Loïc Maury lmaury at gmail.com
Tue Feb 18 15:09:48 UTC 2014


Hello,

I tried to launch some program with run-program for example
"notepad" "cmd" etc but that doesn't work.

For cmd, it seem returned without the cmd prompt
and notepad is blocked, without show the window.

linux-files.lisp contain a function create-windows-process.

But it seem the problem is with the fill of : STARTUPINFO structure
http://msdn.microsoft.com/en-us/library/windows/desktop/ms686331(v=vs.85).aspx

in the lisp code we have a member : (setf (pref si
#>STARTUPINFO.wShowWindow) #$SW_HIDE)

I have changed this to #$SW_SHOWDEFAULT, and notepad window
appear.

I tried a c code of CreateProcessW without fill the STARTUPINFO struct,
just declare it : "STARTUPINFOW si;" and pass the pointer
to the function, everything work fine.

I tried the same in lisp code, I have removed the code
 (setf (pref si #>STARTUPINFO ....

and everything work fine too, I have a new cmd.exe launched in separate
window, notepad work well too, and other command I have
launched.

But maybe depend on which version of Windows, to fill differently the
structure ?

Thank you

Loic
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.clozure.com/pipermail/openmcl-devel/attachments/20140218/adfd7a88/attachment.html>


More information about the Openmcl-devel mailing list