[Openmcl-devel] Can't get the sample cocoa CurrencyConverter app to build or run properly

ThutmoseIII Thoth thutmosethree at gmail.com
Thu May 14 19:10:35 PDT 2015


I wish to build cocoa apps with CCL and hopefully IB as well, so I tried to
build and run the example CurrencyConverter application included in the CCL
installation. I followed the instructions from the HOWTO html pages,
specifically the "build_app.html" file, but it did not build correctly. As
soon as I evaluate (ccl::build-application ...) the CCL listener abruptly
closes down and the .app file it writes to the Desktop has a cancel symbol
drawn over it. When I double click the .app file it just opens the CCL

I first tried this on a Mac with Yosemite and a CCL install from macports.
When that didn't work I downgraded to 10.6.3, when that didn't work I tried
10.6.8, when that didn't work I retrieved CCL from the svn repo and tried
again with both the x86cl and x86cl64 versions. I'm not a heavy mac user;
am I doing something wrong? What else can I try?

The following is the information about my mac if this helps (I got it
refurbished or used if that matters):

Macbook Pro (2008)
  Processor: 2.6 GHz Intel Core 2 Duo
  Memory:    4 GB 67 MHz DDR2 SDRAM

If you need more information from me, please let me know.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.clozure.com/pipermail/openmcl-devel/attachments/20150514/923949f9/attachment.htm>

More information about the Openmcl-devel mailing list