[Openmcl-devel] command-line invocation on Mac

R. Matthew Emerson rme at acm.org
Mon Apr 1 22:23:30 PDT 2019

> On Apr 1, 2019, at 9:20 PM, Christopher Stacy <cstacy at dtpq.com> wrote:
> On 4/1/19 8:08 PM, Ron Garret wrote:
>> On Mar 31, 2019, at 5:46 PM, Christopher Stacy <cstacy at dtpq.com> wrote:
>>> I have installed the app (from the App Store) and it works.
>> I just tried this and it didn’t work for me.  I’m on MacOS 10.14.3 and the App Store CCL is 1.11.1.
> I'm OSX 10.11.6 (El Capitan) with 1.11.1 and by "works" I mean it brought up a Listener, and I was able to m-x Find File and it brought up their emacsen .  (As a developer said, this particular app won't work for a command-line / SLIME interface though.)
> If anyone is taking a survey: my  favorite mode of using IDEs in general is to live in GNU Emacs, and have integrated access to the IDE for things like call and class graohs and their other goodies.  Not sure how many other people work like that, rather than just giving up either the IDE or GNU Emacs entirely.  I have done this with Lispworks...I think ACL was all accessible from GNU to begin with...haven't tried this with CCL that I can remember but am betting it will work, just not the app store version.

On the other hand, you can load swank into a running instance of the Mac App Store version of CCL and then connect to it from your Emacs. That works fine.

If you get slime from Quicklisp, you'd start the App Store CCL and say:

(ql:quickload :swank)
(swank:create-server :dont-close t)

And then from Emacs, say "M-x slime-connect".

> For the Mac I'm stuck at El Capitan for the foreseeable future. I plan to be doing most of my development on Linux (Debian at this moment).

The App Store CCL runs fine on El Capitan.  It doesn't run fine on Mojave.  Apple rejected the update I submitted to make it compatible, and I haven't tried to make another submission.


More information about the Openmcl-devel mailing list