[Openmcl-devel] asdf in command line CCL

Paul Krueger plkrueger at comcast.net
Fri May 28 08:25:09 PDT 2021

I’ve been using asdf and quickload for a while in the IDE. Now I’m trying to just do the same thing in the command line version of CCL (downloaded from the GIT repository due to a suggestion from Matthew Emerson).

I’ve tried various ways to require or load asdf, but always get the same result shown below. Can anyone suggest what I might be doing wrong? Alternatively, is there anything useful I can do in the debugger to figure out what the problem is.  And before you ask, the file does exist and a probe-file finds it.


Clozure Common Lisp Version 1.11.5/v1.11.5  (DarwinX8664)

For more information about CCL, please see http://ccl.clozure.com.

CCL is free software.  It is distributed under the terms of the Apache
Licence, Version 2.0.
? (load "home:common-lisp;asdf.lisp")
sigreturn returned
? for help
[69610] Clozure CL kernel debugger: :b
[69610] Clozure CL kernel debugger: current thread: tcr = 0x102e30, native thread ID = 0x307, interrupts enabled

(#x0000000000647EE0) #x00003000004794E4 : #<Function %NANOSLEEP #x00003000004791EF> + 757
(#x0000000000647F68) #x0000300000486DBC : #<Function HOUSEKEEPING-LOOP #x0000300000486BDF> + 477
(#x0000000000647FB8) #x0000300000487384 : #<Function (:INTERNAL (TOPLEVEL-FUNCTION (LISP-DEVELOPMENT-SYSTEM T))) #x000030000048727F> + 261
[69610] Clozure CL kernel debugger: 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.clozure.com/pipermail/openmcl-devel/attachments/20210528/fd2c5d93/attachment.htm>

More information about the Openmcl-devel mailing list