<html xmlns="http://www.w3.org/TR/REC-html40" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:v="urn:schemas-microsoft-com:vml">

<head>


<style>
<!--
 /* Font Definitions */
 @font-face
        {font-family:"Cordia New";
        panose-1:2 11 3 4 2 2 2 2 2 4;}
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
        {font-family:Tahoma;
        panose-1:2 11 6 4 3 5 4 4 2 4;}
@font-face
        {font-family:Consolas;
        panose-1:2 11 6 9 2 2 4 3 2 4;}
 /* Style Definitions */
 p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
p.MsoPlainText, li.MsoPlainText, div.MsoPlainText
        {mso-style-priority:99;
        mso-style-link:"Plain Text Char";
        margin:0in;
        margin-bottom:.0001pt;
        font-size:10.5pt;
        font-family:Consolas;}
p.MsoAcetate, li.MsoAcetate, div.MsoAcetate
        {mso-style-priority:99;
        mso-style-link:"Balloon Text Char";
        margin:0in;
        margin-bottom:.0001pt;
        font-size:8.0pt;
        font-family:"Tahoma","sans-serif";}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri","sans-serif";
        color:windowtext;}
span.PlainTextChar
        {mso-style-name:"Plain Text Char";
        mso-style-priority:99;
        mso-style-link:"Plain Text";
        font-family:Consolas;}
span.BalloonTextChar
        {mso-style-name:"Balloon Text Char";
        mso-style-priority:99;
        mso-style-link:"Balloon Text";
        font-family:"Tahoma","sans-serif";}
.MsoChpDefault
        {mso-style-type:export-only;}
@page Section1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.Section1
        {page:Section1;}
-->
</style>
<!--[if gte mso 9]><xml>
 <o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
 <o:shapelayout v:ext="edit">
  <o:idmap v:ext="edit" data="1" />
 </o:shapelayout></xml><![endif]-->
</head>

<body vlink="purple" link="blue" lang="EN-US">

<div class="Section1">

<p class="MsoPlainText">thanks for the help john<o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">but i could use some more of you insight<o:p></o:p></p>

<p class="MsoPlainText">i did as you stated in your reply,<o:p></o:p></p>

<p class="MsoPlainText">though i have emacs 22.3 and slime-2010-01-07<o:p></o:p></p>

<p class="MsoPlainText">i did remane slime to slime when i put in the
emacs/site-lisp folder<o:p></o:p></p>

<p class="MsoPlainText">when i start emacs i get this error<o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">("C:\\emacs-22.3\\bin\\emacs.exe")<o:p></o:p></p>

<p class="MsoPlainText">Loading encoded-kb...done<o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">An error has occurred while loading `c:/.emacs':<o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">Symbol's function definition is void: add-to-lisp<o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">To ensure normal operation, you should investigate and
remove the<o:p></o:p></p>

<p class="MsoPlainText">cause of the error in your initialization file. Start
Emacs with<o:p></o:p></p>

<p class="MsoPlainText">the `--debug-init' option to view a complete error
backtrace.<o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">For information about GNU Emacs and the GNU system, type
C-h C-a.<o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">when i ran it with --debug-init i got,<o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">Debugger entered--Lisp error: (void-function add-to-lisp)<o:p></o:p></p>

<p class="MsoPlainText"> (add-to-lisp (quote load-path) "C:/emacs-22.3/site-lisp/slime/")<o:p></o:p></p>

<p class="MsoPlainText"> eval-buffer(#<buffer *load*> nil
"c:/.emacs" nil t) ; Reading at buffer position 107<o:p></o:p></p>

<p class="MsoPlainText"> load-with-code-conversion("c:/.emacs"
"c:/.emacs" t t)<o:p></o:p></p>

<p class="MsoPlainText"> load("~/.emacs" t t)<o:p></o:p></p>

<p class="MsoPlainText"> #[nil "<span style="font-family:"Cordia New","sans-serif""></span><o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">i also have a folder named .emacs and one named .slime<o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">thanks again<o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">mark<o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">Date: Sun, 10 Jan 2010 19:26:34 -0500<o:p></o:p></p>

<p class="MsoPlainText">From: John Federico <johnrico@gmail.com><o:p></o:p></p>

<p class="MsoPlainText">Subject: Re: [Openmcl-devel] new to lisp pointers needed<o:p></o:p></p>

<p class="MsoPlainText">To: openmcl-devel@clozure.com<o:p></o:p></p>

<p class="MsoPlainText">Message-ID:<o:p></o:p></p>

<p class="MsoPlainText"> <482d44df1001101626g79db283sf878d828e048fde9@mail.gmail.com><o:p></o:p></p>

<p class="MsoPlainText">Content-Type: text/plain; charset=ISO-8859-1<o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">Mark,<o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">I just went through this recently on Vista 32 bit
(although I set up emacs and slime a while back). Here is how I remember doing
it:<o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">(1) I installed emacs into its own directory on the C:
drive, in my case C:\emacs-22.2-bin-i386<o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">(2) I installed slime into a subdirectory of the emacs
folder:<o:p></o:p></p>

<p class="MsoPlainText">C:\emacs-22.2-bin-i386\emacs-22.2\site-lisp\slime<o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">(3) I installed CCL into its own directory on the C:
drive, in my case C:\ccl<o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">(4) I edited my .emacs file to add:<o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">(setq inferior-lisp-program
"c:/ccl/wx86cl.exe") (add-to-list 'load-path
"C:/emacs-22.2-bin-i386/emacs-22.2/site-lisp/slime/")<o:p></o:p></p>

<p class="MsoPlainText">(require 'slime)<o:p></o:p></p>

<p class="MsoPlainText">(slime-setup)<o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">[To edit my .emacs file, I launched emacs and did c-x, f
then entered "~/.emacs" without the quotes. That put me into the
correct location.<o:p></o:p></p>

<p class="MsoPlainText">Also note that you have to use a "/" and not a
"\" in emacs when typing file paths.]<o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">Once that is set up, you should be able to M-x slime, and
it should work.<o:p></o:p></p>

<p class="MsoPlainText"><o:p> </o:p></p>

<p class="MsoPlainText">-John<o:p></o:p></p>

<p class="MsoNormal"><o:p> </o:p></p>

</div>

</body>

</html>