[Openmcl-devel] Using OpenMCL with Aquamacs + Slime doesn't work

Gary Byers gb at clozure.com
Fri May 8 19:51:17 UTC 2009


I don't use Aquamacs or Slime regularly, but I just downloaded what
seemed to be the latest Aquamacs (1.7) from aquamacs.org, did

M-: (setq inferior-lisp-program "/path/to/ccl64")

and

M-x slime

, and it told me that it had no idea what slime was.  I looked
around inside the application bundle and didn't see anything
that looked like it was part of slime, which suggests that
Aquamacs is (no longer ?) bundling slime.

Daniel's message (which arrived as I was typing this) suggests
that he uses a slime checked out from the slime project's CVS
(or whatever they use) tree.

If you're still getting the same error you were getting before
and slime isn't part of Aquamacs, that suggests that you still
have an old (and perhaps buggy) version of slime on Aquamacs'
load path somewhere. IIRC, you may be able to do something like

M-x find-load-file <return> slime <return>

to have Emacs tell you where it's finding the slime that it's
finding.



On Fri, 8 May 2009, Manuel Weikert wrote:

> 2009/5/8 David Reitter <reitter at cmu.edu>:
>
>>
>> So you want to use the latest Aquamacs release along with a recent build of
>> SLIME, both available as point-and-click installers from
>> http://aquamacs.org.
>>
>
> Hmmm... I have brand new versions of Aquamacs and Slime. Both
> downloaded from aquamacs.org a few days ago. But I had an older
> Version running before, so I erased all available files belonging to
> Aquamacs and Slime and installed it again. Result: the same error...
> The website says that the version of Slime available for download
> works fine with OpenMCL... Well, not for me...
> _______________________________________________
> Openmcl-devel mailing list
> Openmcl-devel at clozure.com
> http://clozure.com/mailman/listinfo/openmcl-devel
>
>



More information about the Openmcl-devel mailing list