[Openmcl-devel] error in installing ACL2 with CCL

Renzo Orsini orsini at unive.it
Tue Sep 3 05:38:20 UTC 2013


Your diagnosis is perfectly correct: the culprit was in my .ccl-init.lisp file!  

In the installation instructions of ACL2 no mention was made to the init file, so I missed checking it.

I suppose I should put something in the file that says: if loaded from command line, do not execute this stuff...

Thank you very much Gary!

Renzo Orsini


On Sep 3, 2013, at 24:39 , Gary Byers <gb at clozure.com> wrote:

> As far as I know:
> 
> 1) CCL doesn't spontaneously announce that a package named "GUI" doesn't
>    exist ...
> 2) An error to that effect might by signaled by (for instance) attempts
>    to read a package-qualified symbol (GUI::FOO) in an environment where
>    no package of that name exists; such an attempt might be made by
>    code which tries to load or compile a file that contains such a symbol
> 3) Nothing in the ACL2 build process (or in code that runs when a
>    saved_acl2 starts up) attempts to compile or load such a file.
> 
> That pretty strongly suggests that the reference to the GUI package is
> coming from your init file (typically ~/ccl-init.lisp).  If you have
> such a file and rename it before trying to build ACL2, does the error
> still occur ?  (Note that if it does, you may get the same error when
> trying to run CCL from the command line; you say that that works, but
> I think that some skepticism is justified.  The "GUI" package exists in the IDE ("Clozure CL64.app") but not in the command-line executable.)
> 
> If this isn't the problem, it's hard to guess what the problem is.  It
> might be easier to guess if you hadn't decided that the messages that
> preceded the error message weren't important.  If you don't know whether
> some information is important or not, it's almost always going to be
> preferable to provide too much information than to provide too little.
> 
> On Mon, 2 Sep 2013, Renzo Orsini wrote:
> 
>> When trying to install ACL2 with CCL, I receive the following message:
>> 
>> $ make LISP=/Applications/ccl/dx86cl64
>> 
>> ... messages...
>>> Error: There is no package named "GUI" .
>>> While executing: CCL::%PARSE-TOKEN, in process listener(1).
>>> Type :GO to continue, :POP to abort, :R for a list of available restarts.
>>> If continued: Retry finding package with name "GUI".
>>> Type :? for other options.
>> 1 >
>> ....
>> then the installation proceed and terminate.
>> 
>> When I call the ACL2 executable, saved_acl2, the same error message is printed.
>> 
>> Is this an error arising from ACL2 or from my installation of CCL (which works both in terminal and from the Clozure CL64.app) ?
>> (I have the last version of CCL2)
>> 
>> Thank you very much.
>> 
>> Renzo Orsini
>> 
>> _______________________________________________
>> Openmcl-devel mailing list
>> Openmcl-devel at clozure.com
>> http://clozure.com/mailman/listinfo/openmcl-devel
>> 
>> 




More information about the Openmcl-devel mailing list