[Openmcl-devel] [Newbie] Unable to compile or load "apple-objc.lisp"

Dave Newman tinman at pobox.com
Tue May 20 11:10:43 PDT 2003


Thanks for the reply.

>I suppose that there could be, but the Cocoa examples are generally
>fairly small and they satisfy their dependencies by using REQUIRE
>to load what they need.

Okay. I didn't understand REQUIRE would do the work for me. I'll 
stick with that once I get the path issue straightened out.

>If this doesn't work for you (returns some physical pathname that doesn't
>correspond to where the lisp is installed), you might want to look at
>".../ccl/doc/HTML/shell-script.html", which explains this in greater

The openmcl script is there and configured to point to the correct 
directory, but I think I just figured out the problem. I have been 
running openmcl from emacs via ILisp. I just tried (require "COCOA") 
in OpenMCL run directly from a terminal shell and it worked. I was 
able to get the COCOA listener up and running.

This tells me that I have ILisp configured incorrectly. I see now 
that it is launching dppccl directly instead of launching the openmcl 
script. I'll change that and see what happens. Yes, that works.

Thanks for the help!


Openmcl-devel mailing list
Openmcl-devel at clozure.com

More information about the Openmcl-devel mailing list