[Openmcl-devel] Clozure CL 1.2-rc1 available

Osei Poku osei.poku at gmail.com
Mon Apr 28 19:56:18 PDT 2008

On Apr 28, 2008, at 10:44 PM, Gary Byers wrote:

> I ran into this; ccl/library/chud-metering.txt should note that 4.5.0
> seems to work, but that "later versions may have problems".  I don't
> know if the problems in the 4.6.0 that comes with the iPhone SDKs
> are the result of intentional changes or unintentional ones.  In the
> latter case, things might be fixed by the next XCode release.
> I don't remember anything in the 4.6.0 release notes that mentioned
> that support for .spatch files had been dropped, but I didn't look too
> hard.  I'll try to reinstall iPhone SDK du jour and see if there's
> evidence that the change(s) were intentional.

One thing that I did notice was the a missing section in the 4.6.0  
Shark User Guide (I think Appendix B.3) that specifies the mpatch/ 
spatch file format.  The same section is still available online(apple  
developer documentation) and in the 4.5.0 Shark User guide.

> On Mon, 28 Apr 2008, Osei Poku wrote:
>> Hmm,
>> Never mind. Downgrading CHUD to 4.5.0 works.  I think 4.6.0 came  
>> from the iphone sdk.
>> Thanks.
>> On Apr 28, 2008, at 2:34 PM, Osei Poku wrote:
>>> Hi,
>>> On Apr 20, 2008, at 10:55 AM, Gary Byers wrote:
>>>> - profiling via Apple's CHUD tools (finally) works on 64-bit  
>>>> versions of
>>>> CCL.  See ccl/library/chud-metering.txt for details.
>>> How exactly does this work now?  I am using the dx86cl64 version.
>>> I call (chud:meter (null (fact 10000))) and some "magic" happens  
>>> then Shark pops up and displays the just run session.
>>> I see the spatch file and the session files obviously there.   
>>> However, the portions of the session that I am interested in are  
>>> still missing. Specifically, it seems that the spatch file is not  
>>> being used correctly.  I tried adding the session directory to the  
>>> search path for source files in Shark Preferences. But still  
>>> nothing.
>>> Any thing that I missed?  The version of shark on my machine is  
>>> 4.6.0.
>>> Osei

More information about the Openmcl-devel mailing list