[Openmcl-devel] directory, create-directory, ...

Hans Hübner hans at huebner.org
Mon Oct 6 05:42:26 PDT 2008

On Mon, Oct 6, 2008 at 14:51, Jon S. Anthony <j-anthony at comcast.net> wrote:
> I have tried these on both Mac and Linux and they behave the same, and
> that is to do nothing.  They don't error, but just return.
> create-directory returns the multiple values: path of the supposedly new
> directory and nil:
> (create-directory "/home/jsa/TEST") => #p"/home/jsa/TEST", NIL
> But the directory isn't created.  I also haven't found what the MODE
> keyword is supposed to be or do.
> directory returns nil whether or not the directory given exists:
> (directory "/home/jsa") => nil
> (directory "/gobbledegook") => nil
> I also couldn't find the meaning of the various keywords to this either,
> but tried various permutations of :files t, :directories t, etc. with no
> apparent effect.
> I tried both with path syntax input as well: #p"/home/jsa/TEST",
> #p"/home/jsa", etc.  Nothing.
> Anyone have any ideas??

Your directory pathnames need to end in a slash, as in #P"/home/jsa/".
 DIrectories and files are treated differently in the CL pathname
system.  See http://gigamonkeys.com/book/files-and-file-io.html#filenames
for a discussion on the history and usage of pathnames.


More information about the Openmcl-devel mailing list