[Openmcl-devel] IDE compilation failure on darwinppc64

Garth Corral gcorral at abode.com
Wed Sep 10 21:28:14 PDT 2008

Hi all,  I've searched the list archives and the clozure wiki but can  
find not reference to my issue so I thought I post here to see if  
anyone can help.

I've recently installed ccl on my G5 system running OS X 10.5.4.  I'm  
new to clozure but as near as I can tell, all seems well (using ppc64  
just because). Until, that is, I tried building the IDE using the  
procedure in the manual.  It fails for me with the following:

Welcome to Clozure Common Lisp Version 1.2-r10552  (DarwinPPC64)!
? (require :cocoa-application)
 > Error: Unknown foreign type: :<MARG>
 > While executing: %PARSE-FOREIGN-TYPE, in process listener(1).
 > Type :POP to abort, :R for a list of available restarts.
 > Type :? for other options.
1 >

I've tried this with the 1.2 tarball, updated from svn, and with fresh  
trunk checkout.  They all fail in the same way.  It worked fine for me  
with the ppc32 image as well as X8664 on my MacBook Pro.  I searched  
around to see if this was a known issue or it simply isn't supported  
but I came up empty.  Any assistance with this will be appreciated.   
It isn't absolutely essential that I use the 64 bit image but if I can  
get it to work, why not?  ;-)

Thanks in advance,


More information about the Openmcl-devel mailing list