[Openmcl-devel] Clozure CL 1.3-RC1 available

John Stoneham captnjameskirk at yahoo.com
Sat Feb 14 06:02:31 PST 2009

> Let me see if I can create a little program that'd tell us what's
> different.  OK, if I remembered to attach it, the source should be
> enclosed.  Compile and run via:
> shell> cc -m32 -g -o mach32 mach32.c
> shell> ./mach32
> When I run it (on a Core 2 Duo), I get:
> Mach exception: 2 (EXC_BAD_INSTRUCTION) with 2 codes: 0x1 0x0
> If you get substantially different output, that'd be good (in the
> sense that it'd tell us what's different and suggest how to handle it.)

I tried it under both Tiger and Leopard just to be sure there were no differences between the systems, and here's the output I get under both:

Mach exception: 2 (EXC_BAD_INSTRUCTION) with 2 codes: 0xd 0x7ea 

So I assume this is good news, since it's different from your output, but it's the same under both Tiger and Leopard on my machine.

Feel free to throw anything else my way that needs testing.


More information about the Openmcl-devel mailing list