[Openmcl-devel] Slime/Clozure/Windows C-c C-c not working

Matt Lamari matt.lamari at gmail.com
Sun Jul 26 09:27:20 PDT 2009

Thank you very much!

I got to see "slime" actually run for the first time when someone on
#lisp explained to me how to run CCL as an independent Swank server and
use slime-connect.

Slime-connect works and gets to slime on both GNU Emacs and XEmacs

XEmacs persists in failing to start up Slime (for me).

What got me past the problem in GNU Emacs was referring to WX86CL64.exe
as you have done, rather than the CCL64 script.

So to summarize (using the same slime/swank):
Slime-connect to a server:  Both Emacs'
M-x Slime :  GNU Emacs only

(Note - I'm not saying XEmacs has anything wrong with it, just that I
could not get Slime to start properly, in Win6, with the kind of
settings that worked in GNU Emacs).

I'm somewhat new to emacs and less familiar with things unixy than many
on this list.  I've been shielded from a lot of this via Lispworks. 
What seems like trivial adjustments to emacs settings would be
incredibly daunting to someone coming from the Microsoft DevStudio who's
never seen lisp or emacs before.

I think I'll try to come up with an end-to-end blow-by-blow foolproof
set of windows-specific instructions for this windows audience (tested
on a clean VM windows install).

Helmut Eller wrote:
> * Matt Lamari [2009-07-26 13:30+0200] writes:
>> Would you be able to email me more of your config?
>> I moved to (non-Xemacs) GNU Emacs to try to standardize on your
>> results.  (Reinstalling GNU Emacs and downloading a new/latest slime)
>> With Gnu Emacs I cannot start slime at all - I get the error "Spawning
>> child process: invalid arguments".  I've tried entering the link to
>> CCL/Scripts/CCL64 in all the path forms I could think of but it didn't help.
> There might be a problem with spaces in filenames.
> My setup for Windows is:
> (add-to-list 'load-path
>               "i:/Documents and Settings/helmut/lisp/slime-2009-06-06/")
> (require 'slime-autoloads)
> (slime-setup '(slime-repl))
> (setq slime-lisp-implementations
>       '((ccl ("i:/Documents and Settings/helmut/lisp/ccl/wx86cl.exe"))))
> A few more points: the *inferior-lisp* buffer displays the output of the
> CCL process and has a REPL.  This buffer is in "comint" mode.  If you
> just need comint mode you can also use M-x run-lisp (or C-u M-x run-lisp
> to give the correct filename).
> Slime is distinct from comint mode and uses a TCP socket in the
> background.  Slime only needs the comint buffer at startup and displays
> it so that you can see error messages.  If you see the *inferior-lisp*
> buffer it doesn't necessarily mean that Slime started; it only means
> that the CCL process started.
> Also, pressing C-c C-c in the comint buffer doesn't seem to work (yet)
> on Windows.  Slime can use a different mechanism by sending something on
> the above mentioned socket which tends to work better.
> Helmut
> _______________________________________________
> Openmcl-devel mailing list
> Openmcl-devel at clozure.com
> http://clozure.com/mailman/listinfo/openmcl-devel

More information about the Openmcl-devel mailing list