[Openmcl-devel] Problems with openMCL slime and Aquamacs (Mac OS X)

Robert Goldman rpgoldman at sift.info
Fri Oct 23 12:36:51 PDT 2009

Philippe Sismondi wrote:
> Ok, thanks Robert. I tried your suggestion. I started ccl directly from
> the command line and loaded asdf.lisp without problem. I tried this
> about 20 times, but no errors occurred.
> Any hints as to what I might try next? I note that one of the available
> restarts allows reloading swank-asdf.lisp. Does that perhaps mean there
> is some slime-related problem after all?

Yes, this /does/ suggest a slime-related problem.

Possibly a mismatch b/w your version of SLIME/SWANK and your version of

A next step would be to figure out if this is CCL-specific.  I hesitate
to ask you to do this, because it's a pain in the butt, but one way to
diagnose would be to install either SBCL or an ACL trial edition, and
try doing the exact same thing, starting up SLIME and loading asdf.lisp,
only with the other lisp.

If that works, then you know the problem is asdf + SLIME + CCL as
opposed to just asdf + SLIME.

OTOH, if that breaks, too, then the problem isn't CCL, and you should
probably move this discussion to some SLIME mailing list.  We know the
problem isn't ASDF proper, because ASDF loads fine.

Sorry I can't offer a better solution.  Someone who is more familiar
with the innards of SLIME and/or CCL, might be able to eyeball your
backtraces and figure out from them what's going wrong, but I'm not that


> On 2009-10-23, at 12:18 PM, Robert Goldman wrote:
>> Philippe Sismondi wrote:
>> [...snip...]
>>> ========
>>> I get these errors whether I use the latest asdf.lisp (from the asdf
>>> site) or the one that comes with ccl.
>>> I am running OS X 10.6 Snow Leopard. I re-installed all relevant
>>> pieces (Aquamacs, slime, and openMCL/ccl today to make sure I am up to
>>> date. This did not help. I get the same problems whether I use 32- or
>>> 64-bit versions of ccl.
>>> I have this version of ccl/openmcl:
>>>     ccl: Version 1.3-r11936
>>> I have the Oct. 22 build of slime, downloaded from the Aquamacs site.
>>> When slime loads correctly it shows this in the slime-repl buffer:
>>>     ; SLIME 2009-10-21
>>> I have Aquamacs distribution 1.9.
>>> Is there a known problem with this? I see that there have been some
>>> issues from time to time in the past that may be related, but my
>>> googling attempts to sort it out did not reveal anything informative.
>> This looks like a simple ASDF + CCL problem, with emacs being a red
>> herring.
>> Suggestion:  start CCL in a terminal window, with no emacs and no slime,
>> and then load asdf.lisp and see what happens, then get back to us.
>> best,
>> r

More information about the Openmcl-devel mailing list