[Openmcl-devel] Error compiling 1.4 IDE

R. Matthew Emerson rme at clozure.com
Mon Jan 4 17:50:23 UTC 2010


On Jan 4, 2010, at 6:25 AM, Lawrence E. Bakst wrote:

> I did a fresh check out of 1.4 from svn and tried to build the cocoa ide and got the following error after I did (require 'COCOA-APPLICATION). Any ideas?
> 
> ;Loading #P"ccl:cocoa-ide;hemlock;bin;openmcl;table.dx32fsl.newest"...
> ;Compiling "/Volumes/std/openmcl/ccl/cocoa-ide/hemlock/src/modeline.lisp"...
> ;Loading #P"ccl:cocoa-ide;hemlock;bin;openmcl;modeline.dx32fsl.newest"...
>> Error: Modeline field #<Hemlock Modeline-field :HEMLOCK-LITERAL> already exists.
>> While executing: MAKE-MODELINE-FIELD, in process listener(1).
>> Type cmd-/ to continue, cmd-. to abort, cmd-\ for a list of available restarts.
>> If continued: Use the new definition for this modeline field.
>> Type :? for other options.
> 1 > ^Z

I just tried a fresh checkout and (require 'cocoa-application) worked for me, but I was running the lisp in a terminal window.

(From the error message you quote, I guess that you might have been running the lisp via MCLIDE?)




More information about the Openmcl-devel mailing list