[Openmcl-devel] svn commit question

R. Matthew Emerson rme at clozure.com
Wed Jan 19 15:38:37 PST 2011

On Jan 19, 2011, at 6:07 PM, Paul Krueger wrote:

> Sorry to bother you, but I haven't tried to check in anything since the contrib directory hierarchy was changed to include the cocoa-ide subdirectory. I did a completely new checkout of the tree, did all the necessary SVN stuff to add my new files etc. SVN status looks like it should. 
> The directions Gary gave me previously were to do the following:
> So, in general, you'll want to do something like:
> shell> cd ccl
> shell> scripts/svn-switch contrib
> shell> cd contrib
> shell> mkdir pkrueger
> shell> svn add -m "new" pkrueger
> shell> cd ccl/contrib
> shell> svn commit -m "new stuff from pkrueger" pkrueger
> Of course I have the directory already, so what I did was what I have done before:
> [Paul-Kruegers-Mac:/Applications/ccl] paul% scripts/svn-switch contrib
> Relocating /Applications/ccl/contrib
> [Paul-Kruegers-Mac:/Applications/ccl] paul% cd contrib
> [Paul-Kruegers-Mac:/Applications/ccl/contrib] paul% svn commit -m "App Developer Tools from pkrueger"
> which came back immediately, so I knew something was wrong. SVN status there shows:
> [Paul-Kruegers-Mac:/Applications/ccl/contrib] paul% svn status
> ?       cocoa-ide
> so I tried to drop down to my directory and commit and got:
> [Paul-Kruegers-Mac:/Applications/ccl/contrib] paul% cd cocoa-ide/krueger
> [Paul-Kruegers-Mac:contrib/cocoa-ide/krueger] paul% svn commit -m "App Developer Tools from pkrueger"
> svn: Commit failed (details follow):
> svn: Server sent unexpected return value (403 Forbidden) in response to MKACTIVITY request for '/publicsvn/openmcl/!svn/act/aa18c98c-a5e2-402e-8b2e-cb8568215e66'
> I'm sure I must need to do something else, but I find the mechanics of what the svn-switch stuff is actually doing a little confusing, so I'm not sure how to adjust for the new cocoa-ide directory. I thought I'd ask before blindly trying things that might make the situation worse.

I moved (most of) the cocoa-related contribs into that new cocoa-ide directory, as you see. It is also an svn external, so you'll need to fix it up be doing the following:

$ cd ccl
$ scripts/svn-switch contrib/cocoa-ide

Or, equivalently
$ cd contrib/cocoa-ide
$ svn switch --relocate http://svn.clozure.com svn+ssh://svn.clozure.com/usr/local

That will tell svn to use ssh (and your keys) rather than http, and your commit should succeed.

Feel free to send private mail if you need more help sorting this out.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.clozure.com/pipermail/openmcl-devel/attachments/20110119/6d34c2c6/attachment.htm>

More information about the Openmcl-devel mailing list