[Openmcl-devel] App Development Tools Contrib

Paul Onions wibble37 at mac.com
Sat Jan 22 00:58:19 PST 2011

Hi Paul,

Console log below, though to my untrained eye it's not very revealing:  
a segmentation fault by CCL.

22/01/2011 08:39:19 fseventsd[41] callback_client: ERROR:  
d2f_callback_rpc() => (ipc/send) timed out (268435460) for pid 79428
22/01/2011 08:39:19 fseventsd[41] client: 0x810e00 : USER DROPPED  
22/01/2011 08:39:20 ReportCrash[79435] Formulating crash report for  
process dppccl[79428]
22/01/2011 08:39:26 ReportCrash[79435] Saved crashreport to /Users/pdo/ 
using uid: 502 gid: 20, euid: 502 egid: 20
22/01/2011 08:39:26 ReportCrash[79435] Saved crashreport to /Users/pdo/ 
using uid: 502 gid: 20, euid: 502 egid: 20
22/01/2011 08:39:24 com.apple.launchd[104]  
([0x0-0x53e53e].com.clozure.Clozure CL-ppc32[79428]) Exited  
abnormally: Segmentation fault

The CrashReporter log is too long to post here, but it starts off as  
follows (with my elisions [...] for a lot of almost identical lines):-

Process:         dppccl [79428]
Path:            /usr/local/lisp/ccl-trunk/Clozure CL32.app/Contents/ 
Identifier:      com.clozure.Clozure CL-ppc32
Version:         Version 1.4-dev (14586M-trunk (PPC32))
Code Type:       PPC (Native)
Parent Process:  launchd [104]

Date/Time:       2011-01-22 08:39:00.293 +0000
OS Version:      Mac OS X 10.5.8 (9L31a)
Report Version:  6
Anonymous UUID:  8FB8271E-9890-4C6C-9F33-84EA391A8ACE

Exception Codes: KERN_PROTECTION_FAILURE at 0x00000000bf7ffb60
Crashed Thread:  1

Thread 0:
0   libobjc.A.dylib               	0x95814904 _class_initialize + 28
1   libobjc.A.dylib               	0x95814930 _class_initialize + 72
2   libobjc.A.dylib               	0x95814930 _class_initialize + 72
3   libobjc.A.dylib               	0x95814930 _class_initialize + 72


506 libobjc.A.dylib               	0x95814930 _class_initialize + 72
507 libobjc.A.dylib               	0x95814930 _class_initialize + 72
508 libobjc.A.dylib               	0x95814930 _class_initialize + 72

Thread 1 Crashed:
0   libSystem.B.dylib             	0xffff8ad8 __memcpy + 824  
1   com.clozure.Clozure CL-ppc32  	0x00014500  
create_thread_context_frame + 48 (ppc-exceptions.c:2562)
2   com.clozure.Clozure CL-ppc32  	0x00015078 openmcl_exc_server + 152  
3   libSystem.B.dylib             	0x918d2e8c mach_msg_server + 364
4   com.clozure.Clozure CL-ppc32  	0x00014740 exception_handler_proc +  
32 (ppc-exceptions.c:2901)
5   libSystem.B.dylib             	0x9188c0d0 _pthread_start + 316

Thread 2:

and so on. If anybody is interested I can send the full report.

Unfortunately, I don't really have any other ideas at the moment. I'm  
not an expert in CCL internals.

Best regards,

On 21 Jan 2011, at 23:31, Paul Krueger wrote:

> I just checked the target for that NIB and it's set to 10.5, so I  
> suspect that isn't really the problem. Given that you got the tools  
> loaded, you would also have loaded the Dev menu nib, so that  
> probably wasn't a good guess on my part.
> Thinking about it, there are a couple of 10.6 specific Objective-C  
> methods that I provide to make things work easier on 10.6 systems,  
> but I provided an alternative set of 10.5 methods for cases where  
> the 10.6 versions aren't called. Although I tested that by removing  
> the 10.6 methods and making sure that everything worked; something  
> might have broken since I first tested it.
> Send that Console information if you can; maybe that will give me a  
> hint.
> Paul
> On Jan 21, 2011, at 5:14 PM, Paul Krueger wrote:
>> It wasn't my intent to do anything that explicitly required 10.6,  
>> but without the ability to test anywhere else I suppose I shouldn't  
>> be all that surprised that something didn't work. Most of this  
>> worked on my system before I upgraded to 10.6 last summer, but who  
>> knows what I did to break things since then.
>> Check the console log for any messages there and let me know if you  
>> see anything interesting; you usually will when things crash (use  
>> the Console application found in /Application/Utilities). The code  
>> depends on the NIB for the window and given that yours hung when  
>> you tried to open a window it's possible that the format of the NIB  
>> changed and the newer version caused a problem on your system (I  
>> was actually a victim of that with a NIB generated by somebody else  
>> once).
>> If console messages lead us in that direction, then one thing we  
>> might try is for me to send the nib in .xib format and let someone  
>> using 10.5 see if that will open in InterfaceBuilder (it might  
>> not). If it did, they could then save it as a .nib. One caveat here  
>> is that whoever does this would need to have also built my lisp- 
>> controller IB plugin and installed it. That's pretty much mandatory  
>> anyway if you want to use the tools going forward. That process is  
>> documented in the "LispController Ref" document (either pdf or rtfd  
>> versions). If somebody wants to try that on a 10.5 system, please  
>> send me email privately and I'll send the .xib version to try. If  
>> that all works I'll check in .xib versions of all my NIB files and  
>> recommend that people convert them for earlier OS versions.
>> BTW, I'm not ungrateful at all, quite the opposite. I want this to  
>> work for as many people as possible.
>> Paul
>> On Jan 21, 2011, at 4:08 PM, Paul Onions wrote:
>>> On 20 Jan 2011, at 15:58, Paul Krueger wrote:
>>>> If you are not interested in developing your own stand-alone  
>>>> Macintosh application using CCL, you can ignore the rest of this  
>>>> email.
>>> ...
>>> Is there a minimal OS version required? I'm on OSX 10.5.8  
>>> (PowerPC) and although I can compile and load your contrib using  
>>> (require :lisp-app-doc), when I select "New Lisp Application" from  
>>> the File menu I get a beach ball followed a few seconds later by a  
>>> crash notification.
>>> BTW I don't want to seem ungrateful here. I can see you have put  
>>> an enormous amount of effort into this and your documentation is  
>>> excellent. I will understand completely if my old system is not  
>>> supported anymore.
>>> Best regards,
>>> Paul
>>> --
>>> Paul Onions
>>> _______________________________________________
>>> Openmcl-devel mailing list
>>> Openmcl-devel at clozure.com
>>> http://clozure.com/mailman/listinfo/openmcl-devel
>> _______________________________________________
>> Openmcl-devel mailing list
>> Openmcl-devel at clozure.com
>> http://clozure.com/mailman/listinfo/openmcl-devel

More information about the Openmcl-devel mailing list