[Openmcl-devel] Updating ccl

Gary Byers gb at clozure.com
Mon May 9 16:31:45 PDT 2011

I imagine that there's some more diagnostic output somewhere; I don't
really know what error code 2 means in this context.

A reasonable guess is that svn tried to replace the running wx86cl.exe
with a newer version.  Windows doesn't allow running executables files
to be replaced (this is a filesystem limitation), and the same limitation
prevents the :FULL T option to REBUILD-CCL from working (that option would
try to recompile and overwrite the running wx86cl.exe.)

Because of this limitation, you basically need to do svn update and build
the kernel outside of the lisp (and with no CCL processes running) and
rebuild the kernel in that same environment.

On Mon, 9 May 2011, Greg Bennett wrote:

> I have recently tiptoed out into the trunk version of ccl to access the
> cocoa material for Windows, on a W7 64bit, professional box running service
> pack 1.
> Using
> (require :cocoa-application)
> I created a listener under wx86cl.exe as the lisp, ie the 32bit version,
> since the cocoa
> stuff does not seem to compile under the 64bit version.
> This day I have tried to update things using
> (ccl:rebuild-ccl :update t :full t)
> with unhappy results:
> :Running 'svn update'.
> : 'svn update' complete.
> >Error: Running "svn update" produce exit status: ERROR. Code 2.
> >while executing: UPDATE-CCL, in process listener(1).
> >Type :POP to abort, :R for a list of available restarts.
> >Type :? for other options.
> Clearly I have missed an important step; any and all assistance appreciated
> Cheers /Greg Bennett

More information about the Openmcl-devel mailing list