[Openmcl-devel] CCL on Android

Stas Boukarev stassats at gmail.com
Tue Nov 22 01:36:58 PST 2011

Stas Boukarev <stassats at gmail.com> writes:

> Gary Byers <gb at clozure.com> writes:
>> Early in the year, I got CCL running (for at least some value of
>> "running") on Android.  It was of somewhat limited utility (there are
>> only so many times that you can call (FACT 1000) on your phone before
>> the thrill wears off), but anything of greater utility - something
>> that could be used to develop Android applications - would have to
>> start somewhere.  I haven't had too much time to work on it since, and
>> when I tried building it from current trunk sources a month or two ago
>> I found that bitrot had set in.  Once in a great while, someone asked
>> about the (fairly old) binaries that were in svn, and the Android port
>> was mentioned in passing in the iOS discussion a few weeks ago.
> I've been able to run CCL on android before and it was crashing
> constantly (I tried to rebuild it, but was only able to build a new
> kernel and not an image, so thanks for the instructions). With the new
> binaries it's now able to successfully load quicklisp. It has some
> trouble with foreign libraries, but I suspect that's because android
> doesn't have a proper libc.
> I'm now able to run my application on android (pure lisp side of it, I
> don't imagine I'll be able to use Qt from Lisp on android any time
> soon). And it even runs in a reasonable amount of time, 5 seconds
> versus .5 seconds on the desktop CCL.
> It'd be nice to get some basic things working, like usocket, right now
> it complains about some undefined foreign functions.
And I forgot to add, I'm running this on a rooted Galaxy S2 with android

With best regards, Stas.

More information about the Openmcl-devel mailing list