[Openmcl-devel] clozure ccl on android

Cyrille Duret cduret at gmail.com
Mon Feb 25 10:46:28 UTC 2013


hello,
I try to setup a running ccl instance on android and followed this thread

http://clozure.com/pipermail/openmcl-devel/2011-November/013183.html

I tried to compile the kernel but without success since I am running
freeBSD, I tried to compile from Windows/cygwin (I don't have linux nor MAC
OS)

I tried to upload the prebuild image (aarmcl, aarmcl.image and aarmcl.so)
from svn but I got an exception :

unhandled exception 11 at 0x50066b68, context->regs at #xbef113d8
received signal 11; faulting address: 0x1
address not mapped to object
? for help
[24515] Clozure CL kernel debugger:


My phone's CPU is

# cat /proc/cpuinfo
Processor   : ARMv7 Processor rev (v71)
BogoMIPS : 509.54
Features : swp half thumb fastmult vfp edsp thumbee neon vfpv3
..
..
Hardware : bravo

Is there any way to cross compile the lisp kernel with windows OS ?

thanks
Cyrille
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.clozure.com/pipermail/openmcl-devel/attachments/20130225/4ddb7ca0/attachment.html>


More information about the Openmcl-devel mailing list