[Openmcl-devel] clozure ccl on android

Gary Byers gb at clozure.com
Mon Feb 25 04:40:21 PST 2013

I've never tried to cross-compile the android CCL kernel using a Windows
version of the Android NDK, but I (naively ?) would expect it work if the
Makefile (ccl/lisp-kernel/androidarm/Makefile) is edited a bit.  You say
that you tried to compile from Windows/cygwin but don't say what you changed
or how it failed; you may have already tried some of this.

1) download http://dl.google.com/android/ndk/android-ndk-r7c-windows.zip;
extract that on the Windows box, ideally somewhere that'd have the Cygwin
pathname "/usr/local/android-ndk-r8c".  If you uave to up it somewhere
else, change the definition of NDK in the Makefile.

2) In a Cygwin shell, not what the command "uname -s" prints (probably
the string "Windows" .)  Look at the NDK directory and see if you can
determine what string is used to name host-specific parts of the NDK
distribution; that may also be "Windows" or something like that.  Edit
the Makefile (the part near the top that uses "uname -s" output to 
set the variable HOST.)

3) cd to the ccl/lisp-kernel/androidarm directory and do "make".  If NDK
or HOST aren't set right, you'll get lots of error messages.

If things go well, one thing that'll happen is that a program named "fixlib"
will get built and run on the host system (the Windows box) to tweak the
"aarmcls.so" library.  It's possible that that needs to be referred to
as "fixlib.exe"

If the make completes, you can move the "aarmcl" and "aarmcl.so" files over
to some directory (/data/local/ or /data/local/tmp, iirc) on the Android device
and try to run aarmcl in the shell.  If that compilains that it can't find a
heap image, build one ...

On Mon, 25 Feb 2013, Cyrille Duret wrote:

> hello,I try to setup a running ccl instance on android and followed this
> thread
> http://clozure.com/pipermail/openmcl-devel/2011-November/013183.html
> I tried to compile the kernel but without success since I am running
> freeBSD, I tried to compile from Windows/cygwin (I don't have linux nor MAC
> OS)
> I tried to upload the prebuild image (aarmcl, aarmcl.image and?aarmcl.so)
> from svn but I got an exception :
> unhandled exception 11 at 0x50066b68, context->regs at #xbef113d8
> received signal 11; faulting address: 0x1
> address not mapped to object
> ? for help
> [24515] Clozure CL kernel debugger:
> My phone's CPU is
> # cat /proc/cpuinfo
> Processor ? : ARMv7 Processor rev (v71)
> BogoMIPS : 509.54
> Features : swp half thumb fastmult vfp edsp thumbee neon vfpv3
> ..
> ..
> Hardware : bravo
> Is there any way to cross compile the lisp kernel with windows OS ?
> thanks
> Cyrille

More information about the Openmcl-devel mailing list